All services and applications are now fully operational.
If you experience any further issues that you believe to be related to this outage, please contact our support team on 01603904090 or at support@voicehost.co.uk.
Posted Jun 12, 2025 - 09:55 BST
Update
These issues have now been partially resolved and access to most applications has been restored. This is still under investigation.
Posted Jun 12, 2025 - 09:28 BST
Identified
We have been made aware that some customers are experiencing issues when attempting to log in to VoiceHost applications. After some investigation we believe we have identified the cause and have raised this to our systems team for further investigation.
Posted Jun 12, 2025 - 08:40 BST
This incident affected: Web Portals, Applications and Services and Telephony Platform (Desktop Softphone).