Virgin have advised that fibre splicers have been requested to site to begin repair work on the fault.
Posted Sep 09, 2026 - 14:38 BST
Update
Following further testing, Virgin engineers have identified a fibre break.
Posted Sep 09, 2026 - 14:16 BST
Update
Virgin engineers have located the impacted infrastructure and are continuing their investigations to determine a root cause.
Posted Sep 09, 2026 - 12:53 BST
Update
Virgin have confirmed they have a network issue affecting Telehouse North and their engineers are working to fix. Further updates will be provided as soon as possible.
Posted Sep 09, 2026 - 11:22 BST
Identified
We are investigating an issue with connectivity to the Virgin network from Telehouse North London.
Posted Sep 09, 2026 - 11:09 BST
This incident affects: Data Network (Layer 2 Services).