Call Failures
Incident Report for
VoiceHost Network
Resolved
Engineers cleared an issue and are monitoring for any recurrence.
Posted
Jan
22
,
2025
-
12:21
GMT
Investigating
Our engineers are investigating call failures affecting some customers connecting via SIP Trunks.
Posted
Jan
22
,
2025
-
12:03
GMT
This incident affected: Telephony Platform (SIP Trunking).
×
Subscribe to Incident
Subscribe to updates for
Call Failures
via . You'll receive .