Some outbound calls fail
Incident Report for VoiceHost Network
Resolved
This incident has been resolved.
Posted Nov 15, 2023 - 14:37 GMT
Identified
We have identified an intermittent issue where some outbound calls fail and our team is working to rectify the issue.
Posted Nov 15, 2023 - 13:12 GMT
This incident affected: Telephony Platform (Outbound Calls).