Network Incident

Incident Report for VoiceHost Network

Resolved

Start: 10 July 2026 – 16:00 BST
Resolved: 10 July 2026 – 18:42 BST

We experienced a DDoS attack which affected access bandwidth to and from our network and resulted in disruption to some services.
The incident has been resolved.
For full details, including our post-incident review, please refer to the Post Incident Report available within the Documents section of your portal.
Posted Jul 10, 2026 - 16:00 BST