We are continuing to work on a fix for this issue.
Posted Mar 18, 2026 - 12:35 GMT
Identified
We have identified an issue with our storage platform. Engineers are currently implementing fixes and restoring services. Some platform generated emails are still failing with an estimated fix and restore within the next 15 minutes
Posted Mar 18, 2026 - 11:43 GMT
Investigating
We have been made aware of an outage affecting multiple systems and are investigating the root cause. We apologise for any inconvenience.
Posted Mar 18, 2026 - 09:30 GMT
This incident affected: Platform API, Web Portals, Applications and Services and Telephony Platform (Desktop Softphone).