Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2025 - 23:00 GMT
Scheduled
One of our providers will be undergoing maintenance which will affect our IP transit and Intra PoP Connectivity to Manchester at Telehouse West. This should not be service affecting as we have resilient services and is anticipated to last 30 mins.
Posted Feb 19, 2025 - 17:33 GMT
This scheduled maintenance affected: Transit / Peering and Network Core.