Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 22:00 GMT
Scheduled
We will be completing a necessary firmware upgrade on one of our core routers. This will cause a brief outage on some data services. If your data service is affected by this maintenance, you will be contacted directly to advise as such.
Posted Jan 20, 2026 - 13:06 GMT
This scheduled maintenance affected: Data Network (Layer 2 Services).