Issues Calling UK Mobile Networks

Incident Report for VoiceHost Network

Update

We have received reports that this issue is still ongoing. Calls to EE mobiles via the VoiceHost platform have been re routed to restore service while the wider issue is investigated by third parties.
Posted Jul 25, 2025 - 12:29 BST

Update

Further information suggests that this is an issue pertaining to EE's network specifically.
Posted Jul 24, 2025 - 12:50 BST

Monitoring

We are aware that users are experiencing issues calling UK mobile networks. This appears to be a widespread issue and is not specific to VoiceHost.
Posted Jul 24, 2025 - 12:11 BST
This incident affects: Third Party Networks.