Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2024 - 22:00 GMT
Scheduled
We will be undergoing maintenance in preparation to upgrade of our LONAP Peering port to 100Gbps in Telehouse North, London. Traffic will flow over other routes whilst the work is being completed.
Posted Nov 12, 2024 - 17:11 GMT
This scheduled maintenance affected: Transit / Peering.