Fibre damage between Telehouse North and Manchester MA4

Incident Report for VoiceHost Network

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 15:29 GMT

Identified

An intra-pop optical cable has been damaged and engineers are working to repair it.
This notice is only informational as traffic is flowing over an alternative route.
Posted Dec 10, 2025 - 09:15 GMT
This incident affected: Network Core.