Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 19, 2025 - 07:00 BST
Scheduled
There will be some upstream broadband network maintenance affecting a small amount of connections on our network. These connections may see a drop within the window of works and should reconnect without issue.
Posted Jun 18, 2025 - 15:58 BST
This scheduled maintenance affected: Data Network (DSL Services).